Nearby Spaces to 407-409 East 70th Street

The following office spaces are available office for lease
Address $ / SF SF Monthly Rent
E 74Th St & Lexington Avenue $60 2,000 $ 10,000
1St Ave & East 74th Street $32 2,500 $ 6,666
Address $ / SF SF Monthly Rent
Address $ / SF SF Monthly Rent
E 71St St & First Avenue $73 5,600 $ 34,066

Lease Office 407-409 East 70th Street

407-409 East 70th Street is a 5 story office building located in the Upper East Side neighbourhood of Manhattan. Further information on rent, lease office 407-409 East 70th Street includes the following. 407-409 East 70th Street does not currently have coworking options available. Despite coworking 407-409 East 70th Street not existing, nearby coworking options do exist. The Zip Code for 407-409 East 70th Street is 10021. 407-409 East 70th Street contains 16,755 of office space for rent. The office space is rated Class B. Construction of 407-409 East 70th Street finished in 1920. Small, medium and large options for rent office 407-409 East 70th Street are available. In addition to nearby office building lease options, sublease 407-409 East 70th Street options may be provided as well.

407-409 East 70th Street Property Overview

Bulding Address: 407-409 E 70th St
Building Alternate address(es): 407-409 E 70th St
Zip Code:10021
Neighborhood:Upper East Side
Borough:Manhattan
Stories:5
Year Built:1920
Building Class:B

Map Location

Find My Space!
  • Green Acres Is the Place for Macerich; The Deal Sheet
  • Billionaire Shows How Small Buildings in NYC Can Mean Big Money
  • Optimal Spaces in the News - New York's Pix11 / Wpix-Tv
  • Fighting rubber ruler measurements
  • Manhattan's Low-Rent Dining in Hiding
  • The NY Fed Is Buying Its Own Building

Don't miss out, join our mailing list

Thank you! we will be in touch.
Please enter a valid email address is required. Your email is required to be at least 3 characters That is not a valid email. Please input a valid email. Your email cannot be longer than 20 characters
Please enter a valid email address is required.